GPO software install errors %%1274


I came in this morning to a bright red BigBrother screen complaining that all servers were having errors…these errors:

Sys: W ‘Mon Nov 21 10:41:22 2011’: Microsoft-Windows-GroupPolicy 1112 – ” The Group Policy Client Side Extension Software Installation was unable to apply one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance.”
Sys: W ‘Mon Nov 21 10:41:22 2011’: Application Management Group Policy 108 – ” Failed to apply changes to software installation settings.  The installation of software deployed through Group Policy for this user has been delayed until the next logon because the changes must be applied before the user logon. The error was : %%1274″
Sys: E ‘Mon Nov 21 10:41:22 2011’: Application Management Group Policy 103 – ” The removal of the assignment of application Snare version 4.0.0.2 from policy Software – Snare 4.0.0.2 64bit for Servers failed. The error was : %%2″
Sys: W ‘Mon Nov 21 10:41:22 2011’: Application Management Group Policy 101 – ” The assignment of application Snare version 4.0.0.2 from policy Software – Snare 4.0.0.2 64bit for Servers failed.  The error was :%%1274″

Yeah…must have been one of the many ‘admins’ creating/linking GPOs without testing, nothing new here…still, this needs to be fixed. Well, the fix was really easy after all, you just need to add a small setting on the GPO. The issue is caused because the computer doesn’t have network connectivity (or full connectivity) while trying to process the package install so probably failing to find the share. This is what needs to be added in the GPO:

Computers Settings -> Policies -> Administrative Templates -> System -> Logon -> Always wait for the network at computer startup and logon: Enabled

A gpupdate/force won’t cut it, you need to reboot the server to stop these warnings.

Big thanks to http://blog.photic.net/index.php/2009/10/the-error-was-1274/

Advertisements

4 thoughts on “GPO software install errors %%1274

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s